My cofactor (mg) is "non bonded" and uncharged

This forum is shown on the index page along with all topics.

Moderator: robpearc

Posts: 1
Joined: Wed Jul 07, 2021 9:52 pm

My cofactor (mg) is "non bonded" and uncharged

Post by ad3616 »

Hello all,

I am an MRes student trying to do some bioinformatics if anyone could help me that would be really appreciated. I have looked to see if my question has been answered and I cannot see the particulars that I am looking for.

I used Phyre2 to model the predicted 3D structure for my protein of interest. Homologues of this protein use Mg2+ which is coordinated to 3 Aspartate residues in the active site. I used both 3DLigandSite and COFACTOR from I-TASSER SUITE to introduce the Mg2+ in my model. However, when looked at it on the site it clearly specified it was the divalent cation but when I opened it on PyMol the formal charge was listed as zero when looking at charge wizard. It also was not co-ordinating as expected with the residues. I tried to manually alter it (PyMOL>alter sele, formal_charge=2) which did not work, I am not sure really why but it never changed.
Another thing was when I was prepping it for docking with autodock vina it noted that the Mg2+ was non-bonded

I also tried to manually edit the PDB file with textedit - writing CONECT bonds to the expected residues based on the homologue and also by specifying the charge (I typed this: HETNAM MG MAGNESIUM ION
(new line)
FORMUL 2 MG MG 2+) which was present on the PDB file of the homologue but it did nothing! I am really not sure how to fix this.

If anyone has any insight that would be amazing!
Sorry if this has been answered already!

Thank you very much,